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Purpose Introduction
1 – Introduction 

Purpose
The Gasboy® PC/1000 User’s Guide is meant to assist you in using the PC/1000 software. It 
contains the system specifications, installation instructions, some information on getting 
started and basic information on some terms associated with PC/1000 and its usage. The Users 
Guide is not intended to be an operation manual for the software. For specific questions on the 
functionality of the software, refer to the Help menu in your PC/1000 software package.

Intended Users
Individuals who have purchased and are authorized to use Gasboy PC Software for Series 
1000 including site personnel and Authorized Service Contractors (ASCs).

Related Documents 
Document Number Title GOLD Library
C08923 Series 1000 Fuel Management System Operation 

Manual
Gasboy Fuel Management Products

C08926 Series 1000 Cardless Fuel Management System 
Operation Manual

Gasboy Fuel Management Products

C36104 PC/1000 Version 1.1.0.8 Patch Gasboy Fuel Management Products

MDE-4480 Series 1000 FleetKey System Operation Manual Gasboy Fuel Management Products
MDE-4488A PC/1000 User’s Guide · April 2008 Page 1



Introduction Abbreviations and Acronyms
Abbreviations and Acronyms
Acronym Definition
ASCII American Standard Code for Information Interchange

CARB California Air Resources Board

CD Compact Disk

CD-ROM Compact Disk-Read Only Memory

CoC Certificate of Compliance

DOS Disk Operating System

FCC Federal Communications Commission

MB Megabyte

ME® Windows Millennium Edition

NCWM National Conference of Weights and Measures

NT® Windows New Technology

NYFD New York City Fire Department 

PC Personal Computer

RAM Random Access Memory

ROM Read-only Memory

VGA Video Graphics Adapter

XP® eXPerience (Microsoft Windows XP)
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System Specifications Installing and Uninstalling PC/1000
2 – Installing and Uninstalling PC/1000

System Specifications
Given below are the minimum specifications for PC/1000 software installation. They may 
differ slightly from the specifications printed on your CD-ROM insert, because additional 
research has shown that these enhanced specifications will improve the performance of your 
PC software.

Fuel Management System
The Fuel Management system is configured to work with the following:

• Gasboy Series 1000, Version 4 or higher - Systems configured to work with CFN Network 
cards or System A cards are not supported.

• FleetKey System (any version) - All fuel management systems being monitored by  
PC/1000 must have the same configuration. If you have multiple system types (that is, 
Series 1000 card or FleetKey system running different configurations), you must have 
separate PC/1000 programs for each type.

Personal Computer
The Personal Computer (PC) is configured to work with the following:

• Microsoft Windows 95, 98, ME, 2000 Professional, Windows NT with Service Pack 4 or 
higher, or Windows XP (Home or Professional).

This software has been designed and tested to work with a PC using Windows English 
(United States) regional settings, where the decimal point character is used as the 
decimal separator. Ensure that your system is set up properly before using this 
software. Gasboy cannot guarantee that the software will work correctly using other 
regional settings.

IMPORTANT INFORMATION

• Pentium or faster processor
• 16 MB RAM required, 32 MB recommended
• 60 MB hard disk space available
• 640 x 480, 800 x 600, 1024 x 768, 256-color or higher VGA display (See Note)
• Mouse
• CD-ROM
• Modem for dial-up connection to Series 1000 Fuel Management System or serial port and 

direct connect cable for direct connection to Series 1000 Fuel Management System
• Windows-compatible Laser or Inkjet printer (See Note)

Note: If you encounter problems with this software, check if you have the latest video and 
printer drivers installed on your computer before you contact Technical Support.
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Installing and Uninstalling PC/1000 Installing PC/1000
Installing PC/1000
Instructions for installing PC/1000 on systems operating on Microsoft Windows 95, 98 or ME 
are given below. If you are using Windows 2000 Professional, Windows NT, or Windows XP 
Professional, ensure that you follow the additional instructions in the section that follows. To 
install PC/1000, proceed as follows:

1 Turn on your computer, and start Microsoft Windows.

2 Insert the Gasboy PC/1000 software CD-ROM into your CD-ROM drive.

3 Click the Start menu.

4 Click Run.

5 Type D:\Setup (On most computers, the CD-ROM drive is D. If your CD-ROM drive is not 
D, type the appropriate letter).

6 Click OK.

7 Follow the on-screen instructions for installation.

Modem Notice

When you add, edit or delete modems in the modem database using Setup/Communications 
Parameters, the modem information is stored in a file called GBModem.ini. This file is 
located in the Program Files\Common Files\Gasboy directory on your PC. If, at any time, 
you choose to uninstall the PC/1000 software, the GBModem.ini file will be removed and any 
changes that have been made to the modem information will be lost. Before uninstalling  
PC/1000, ensure that you save a copy of GBModem.ini, if you want to save your changes.

In version 1.1.0.8, three new Zoom modem configurations were added to PC/1000. If you 
uninstalled a prior version of PC/1000, saved the GBModem.ini file, and have installed 
version 1.1.0.8, you have the following choices:

• If you did not make any changes to the modems in your previous package, simply install 
the new software and the new gbmodem.ini file will be installed.

• If you made changes to the modems and saved a copy of GBModem.ini before 
uninstalling and you are not using one of the new Zoom modems, install the software, then 
copy the file that you saved into the Program Files\Common Files\Gasboy directory. 
This file will replace the new file that was installed with version 1.1.0.8.

• If you made changes to the modems and saved a copy of GBModem.ini before 
uninstalling and you also want to use one of the new Zoom modems, install the new 
version, then use an editor to open the saved GBModem.ini file and the GBModem.ini 
file in Program Files\Common Files\Gasboy directory. Cut and paste content to add any 
changes from the saved GBModem.ini file into the GBModem.ini file in the Program 
Files\Common Files\Gasboy directory.

If you are using the patch to update your software to version 1.1.0.8, follow the patch 
instructions given in “C36104 PC/1000 Version 1.1.0.8 Patch” for details on the 
GBModem.ini file.
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Using PC/1000 for the First Time Installing and Uninstalling PC/1000
Special Instructions for Windows 2000 Professional, Windows NT, and 
Windows XP Professional

Special instructions to be followed while installing the PC/1000 application on Windows 2000 
Professional, Windows NT, and Windows XP Professional operating systems are provided 
below. 

To run the PC/1000 software on a Windows NT PC, you must be running the Windows NT 4.0 
(Service pack 4 or higher) operating system. If you are unsure of which operating system your 
PC is using, proceed as follows:

1 Click Start > Settings > Control Panel. The Control Panel dialog box appears.

2 Double-click the System icon. Your operating system version is displayed on the General tab 
of the System Properties program.

To install and execute PC/1000 software on Windows NT, Windows 2000 Professional or 
Windows XP Professional, you must be an Administrator User or a User who is a member of 
the Administrator Group or a member of the Power Users. If you are not sure how to log-on as 
one of these Users, contact your PC support personnel for details.

Using PC/1000 for the First Time
If you are using PC/1000 for the first time, proceed as follows:

1 Install the PC/1000 software by following the instructions on the inside of the jacket cover of 
the Gasboy Fuel Management Software CD-ROM.

2 Start up the PC/1000 software. Click Start > Programs > PC/1000.

3 When the program starts, do one of the following:

• Register the software (if you purchased a license).

• Run it as a fully functional 30-day demo and register it later.

4 A screen appears, which displays information on the PC/1000 software package setup. Click 
Yes to print a copy of the PC/1000 Setup form. 

Note: If you do not print this form now, you can print it at another time using an editor, such 
as Wordpad. The file is called SetupForm.txt and can be found in the Help subdirectory 
of PC/1000.

5 Fill out all applicable information on the form before attempting to use any of the package 
communication functions.

Note: If you are uncertain about any information requested on the Setup form, contact your 
Gasboy representative to obtain clarification.

6 Once you have finished filling out the Setup form, you can enter your Setup information into 
the PC/1000 package by entering the items under the Setup menu on the PC/1000 Main Page. 
Refer to the package online help system for additional information on setting up the PC/1000 
software.
Note: To assist you in Setup, the System Types Setup form contains a button called 

AutoConfig. When you click this button, the PC software will contact your 1000 site, 
retrieve its settings, and automatically insert them into the PC/1000 package.
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Uninstalling PC/1000
Note: Before uninstalling, refer to Note on page 4.

Windows 95/98/ME
If you are using Windows 95/98, proceed as follows:

1 If PC/1000 for Windows is running, close the application. Shut down the Interbase Guardian 
(appears as a green triangle positioned behind a tower styled PC) by positioning the mouse 
pointer over the Interbase Guardian icon present in the lower right corner of the Windows 
Taskbar. Right-click the icon to display the pop-up menu items. Shut down the Interbase 
Guardian by selecting the Interbase Shutdown option. The Interbase Guardian icon will 
disappear.

2 Click Start > Settings > Control Panel. The Control Panel dialog box appears. Double-click 
Add/Remove Programs in the Control Panel. Select PC 1000 from the list of available 
programs to remove and then click Add/Remove. Follow the on-screen instructions.

Note: On the Remove Shared file? dialog box, click Yes to All to ensure proper removal of 
PC/1000 software.

Windows 2000 Professional/Windows NT/Windows XP Professional

1 You must be logged-on to your PC as an Administrator User or a User who is a member of 
the Power Users or Administrator Group to uninstall PC/1000.

2 If PC/1000 for Windows is running, close the application.

3 Stop the Interbase Guardian and Interbase Server Services.
• For Windows NT: Click Start > Settings > Control Panel > Services.
• For Windows 2000 Professional: Click Start > Settings > Control Panel > 

Administrative Tools > Services.
• For Windows XP Professional: Click Start > Control Panel > Performance and 

Maintenance > Administrative Tools > Services.

4 Select Interbase Guardian from the list, and click Stop. Follow the on-screen instructions. 
To stop the Interbase Server, select Interbase Server from the list and then click Stop. Follow 
the on-screen instructions.

5 Remove PC/1000 using Add/Remove Programs. Double click Add/Remove Programs in the 
Control Panel. Select PC 1000 from the list of available programs to remove, and click Add/ 
Remove. Follow the on-screen instructions.

Note: On the Remove Shared file? dialog box, click Yes to All to ensure proper removal of 
PC/1000 software.
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General PC/1000 Basics
3 – PC/1000 Basics

General
This section contains a visual overview of the software, a general glossary of terms and a set of
tasks to follow for using the PC/1000 software.

A Visual Overview

System Owner

Setup

Password 

Management

System Type

Comm. 

Parameters

Autopoll Setup

Fuel Sites

Lockouts

View Log Files

Transactions

Files

Unscheduled 

Polling

Contact Site

Communications

Raw Trans.

Layout

Reports Utilities

System

Backup

PC/1000

 Main Page

Data Backup

Quit

System 

Restore

Fuel Trans.

Complete

Fuel Trans.

Short Format

Fuel Sites 

Setup

PC System 

Configuration
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PC/1000 Basics Terms to Know
Terms to Know

AutoConfig
The System Types Setup form contains a button called AutoConfig. When you click this 
button, the PC software contacts your Series 1000 or FleetKey site, retrieves its system type 
settings, and automatically inserts them into this form. All systems being monitored by  
PC/ 1000 must have the same configuration. You must have set up communications with your 
fuel site prior to using this option. You must have at least one transaction loaded at the site.

Fuel Site Transactions
Each time a User attempts to obtain fuel at a fuel site, a transaction is generated. Successful as 
well as error transactions may be generated. Transactions may also be generated for events 
such as a fuel delivery or dipstick reading. Typically, raw fuel transactions are accumulated at 
your Series 1000/FleetKey site. You use the PC/1000 package to poll or collect the raw fuel 
transactions from the Fuel Management System, copy them onto the PC for viewing and create 
a RAWTRANS.DAT file for use with other applications.

Polled raw transactions are written to the PC database and stored as part of the 
RAWTRANS.DAT file. Transactions that contain bad data that cannot be stored in the PC 
database are written to a text file called BADTRANS.DAT.

Lockout
Lockout is the process of preventing access to the fuel site. Each fuel site should already have 
a lockout procedure in place. The fields used for lockout on the PC software match whatever is 
configured at the Fuel Management System. Lockout on a Series 1000 or FleetKey is by the 
card or key field and possibly another field, if you have dual lockout. You lock out or activate 
numbers from within the PC/1000 package and then send these changes to your Series 1000 
fuel sites as lockout updates during a polling session.

PC/1000 handles lockouts as follows:
• All lockout changes must be done on the PC (using Files > Lockout form) into either the 

card/key or other lockout file. You can make additions, deletions, or changes. If you do not 
wish to maintain lockouts using the software, you could use an editor to enter lockouts 
into an ASCII file.

• When the Lockout Updates polling action is selected for an unscheduled polling or 
autopoll session, the lockout updates are sent to the site via a lockout update file. The 
lockout update files on the PC are then cleared. If polling is unsuccessful, the lockout 
updates are not sent and remain on the PC until the next polling attempt (either at an 
autopoll time, or at an unscheduled polling attempt).
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Log Files
A polling log is a listing that indicates the outcome of a polling session. It contains messages 
for each site polled stating the date, time and number of transactions polled, and the status of 
all polling actions. PC/1000 stores polling logs from the last seven polling sessions. These 
polling logs are named SESSION1.PLG through SESSION7.PLG. You can have the poll log 
from the current session print automatically by clicking Automatically Send Polling Results 
to Printer on the Setup/Communications Parameters form or print polling logs later from the 
View Log Files form on the Files menu. The most recent log is highlighted by a checkmark.

Each polling log contains date, time polling started, a list of error (status) codes, and the 
following:

• Site number – number of the site polled
• Description – description of the site polled
• Time polling started - the time at which the polling started.
• Connect status – contains OK if connection to site is completed successfully or an error 

code, if unsuccessful.
• Trans status – contains OK if transaction polling completed successfully, an error code if 

unsuccessful, or dashes indicating that the action was not selected or was not executed.
• First Trans – contains number of first transaction polled.
• Last Trans – contains number of last transaction polled.
• Lockout Status – contains OK if lockouts were sent successfully, an error code if 

unsuccessful, or dashes indicating that the action was not selected or was not executed.

Polling (Autopolling, Unscheduled)
Polling is the process by which the PC software contacts a Fuel Management System and 
extracts the raw transactions from the Fuel Management System at the site. Another action, 
updating lockouts, may also be performed at this time. There are two polling options available 
through the Gasboy PC software: autopolling and unscheduled polling.

Autopolling is the easiest and most automatic way to poll your sites on a regular basis. You 
can include all of your sites, or just selected sites. When you set up your Fuel Sites, each site 
that you wish to include in the Autopolling process must have the Autopoll Flag field set to 
YES. You can set the PC software to autopoll up to three times each day when the PC will 
automatically attempt to perform your selected polling actions. If connection cannot be 
established with a site, PC/1000 continues polling other sites and then makes two more 
attempts to re-poll the site. If an error occurs during any polling action, the connection is 
terminated and no further actions are performed for that site. Upon completion, a polling log is 
generated.

Unscheduled polling is a manual polling option that allows you to poll one or more sites at any 
time (on demand). Because autopolling is performed only on sites where the Autopoll Flag is 
set to YES, if you wish to poll other fuel sites (or even one typically scheduled for 
autopolling), you would use unscheduled polling. The available polling actions are identical to 
those you can select under autopolling.
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RAWTRANS
When transactions are polled from your fuel sites, they are stored directly in the PC/1000
database. The default setting for the PC software provides automatic generation of a 
RAWTRANS file upon completion of polling (Communications Parameters form). The 
RAWTRANS file contains all transactions from the current polling session and is used to 
generate reports and to allow you to process your transactions, using another application. 
There are two formats for the RAWTRANS file: Gasboy Standard Windows format and DOS 
format. If you are a new user to Gasboy PC software, use the Gasboy Standard Windows 
format. If you are upgrading from an existing DOS-based PC package, choose the DOS format 
to match the file currently in use. If you have this option disabled, no RAWTRANS file is 
generated and transactions are stored only to the database.

When you perform any operation affecting transactions (add, edit, or delete), you alter the 
transactions in the database. If you have Automatic generation enabled, you are given the 
option to include any edited or manually entered transaction in the next version of the 
RAWTRANS file. Your raw fuel transaction file is created using the Gasboy Standard 
Windows format [your file is named RAWTRANS.DAT (DOS format filename is 
RAWTRANS)]. The Gasboy Standard Windows format is viewable in the online help from the 
Files > Transactions menu.

Reports
Five reports are available: Raw Transactions Layout, PC System Configuration, Fuel Sites 
Setup, Fuel Site Transactions, and Fuel Site Transactions-Short format. Depending on the 
report type, there are user-selectable configuration options that can be applied to customize the 
report and up to four output options: Preview, Print, Disk Unformatted (comma-delimited), 
Disk Formatted (Crystal Report):

• Preview is available for all types and displays the report on your screen. A Print button is 
available if you decide to print it.
Note: A default printer must be loaded on your PC to preview or print reports.

• Print is available for all types and sends the report directly to the printer.
• Disk (Comma Delimited File) is available only with the Fuel Transactions report and 

outputs a comma-delimited file that you can use in external applications. The format of 
this file is based on the sort by criteria you specify. There is also an option to output this 
data with a header line. This is useful for determining the layout of the data when 
preparing it for external use. This format is not available when Summary is selected as an 
output selection.

• Disk (Crystal Report File) outputs the report in Crystal report viewable format to a 
default disk file name or a file name that you specify. Crystal Report files are stored by 
default in the Exports subdirectory of your PC software, but you can change this 
destination if desired.

• In addition to the output options, the Fuel Transactions report can be configured for 
Details or Summary. Details will provide the entire transaction; summary will provide 
totals only.
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Reports Previewer
You can view a saved report when the PC/1000 software is not running by using the program 
GSBPreviewer.exe. This report viewer is present on your PC/1000 software CD under the 
self-extracting file name GSBPrv.exe. Saved reports are stored by default in the Exports 
subdirectory of your PC software, but can be moved elsewhere, if desired. 

To use the Report Viewer
1 From Windows Explorer, navigate to the directory where the GSBPreviewer.exe is located. 

Double click to start the viewer.
2 Select File > Open.
3 In the Open dialog box, navigate to the directory where the saved reports are stored (that is, 

\Gasboy\PC 1000\Exports).
4 Click the desired report file.
5 Click Open.
6 View as desired.

7 Click  to close the report file.
8 Select File > Exit to close the Report Previewer.

Using PC/1000
Given below are some instructions on using PC/1000:

• Explore the package. Select the icons on the Main Page (Setup, Files, Communications, 
and Utilities) and familiarize yourself with what each one does. Each Main Page icon 
brings up a menu containing functions that you can perform. Each menu item brings up a 
form that you can use to define your application or perform operations on your data. Each 
form has a Help button which displays Help screens pertaining to the form or topic 
displayed. If you get into an area of the package and you do not know how to proceed, 
click Help for more information.

• Complete the Setup/System Types form.
• Go to the Setup/Fuel Sites form and verify that all your fuel site information is correct. If 

it is not, make any changes at this time.
• If you intend to use autopolling, go to the Setup/Autopoll Setup form and select your 

options.
• Go to the Files/Lockouts form to enter any lockout information updates you wish to send 

down to your sites.
• Go to the Communications/Contact Site form and ensure that you can successfully 

contact all your fuel sites.
• Once you begin using your PC/1000 package on a regular basis, we highly recommend 

that you set up a schedule for performing regular backups of your PC/1000 data. Backups 
can be performed from the Utilities form and also when you exit the PC/1000 software.
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PC/1000 Basics Using PC/1000
Recommended Daily Sequence
The following table suggests a sequence of events that should be done on a daily basis. Your
actual site procedures may differ.

Selection Sequence Task
Files/View Log Files Check the appropriate polling log file to ensure that all fuel sites

which were set up to be autopolled were successfully polled.

Communications/Unscheduled 
Polling

Perform manual polling of those fuel sites that were unsuccessfully 
autopolled or not polled at all.

Communications/Contact Site Perform fuel site maintenance.

Utilities/System Backup Perform a Backup of your package data.
Page 12 MDE-4488A PC/1000 User’s Guide · April 2008



Using PC/1000 PC/1000 Basics
Gasboy Standard Windows RAWTRANS Layout

Length
Starting 
Column Type

Series 1000 
Tran Field Description

1 1 N System Type

6 2 N Site ID Number

6 8 N Transaction Number

4 14 N CFN Sequence Number, from Site Controller

1 18 N CFN Status Code

8 19 N Total price in hundredths

1 27 N CFN Account to charge

1 28 N Transaction type

2 29 N Product Code

4 31 N Unit price in thousandths

8 35 N Quantity in thousandths

8 43 N Hours in tenths

8 51 N Odometer in tenths

2 59 N Pump Number

8 61 N Date (YYYYMMDD)

4 69 N Time (HHMM)

2 73 N Error code

6 75 A CFN Authorization number

6 81 N Series 1000 Card Number

6 87 N Key1/VM

6 93 N Key2

2 99 N Account Field Length

30 101 A User defined ID fields

20 131 N Manual entry number

1 151 A CFN Device type

1 152 A CFN Device drop

1 153 N CFN # of digits after quantity decimal point

1 154 N FP transaction type

20 155 A CFN Issuer field

4 175 N CFN Expiration date

4 179 N CFN Physical record number

4 183 N MPG in tenths

4 187 N Miles traveled

5 191 N TopKAT Vehicle number

4 196 N TopKAT Vehicle department number

4 200 N TopKAT Manual entry department number

1 204 N TopKAT Pulse rate

2 205 N TopKAT Tank number

6 207 N TopKAT Cum. Vehicle quantity in tenths

6 213 N TopKAT Cum. manual entry quantity in tenths

20 219 N Future expansion
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